[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
TViXiE • View topic - Can't edit movie information

Can't edit movie information

You found a bug? Here is where you can help me track them down.

Can't edit movie information

Postby maxschnell » Fri Aug 19, 2011 8:19 pm

On some of my movies, I can't edit the movie information. I'm not getting any kind of error messages, except for this in the TViXiE.log file:

2011-08-19 20:10:25 Loading '\\...\MovieInfo.tvixie'
2011-08-19 20:10:25 Failed to load '\\...\MovieInfo.tvixie' (There is an error in XML document (46, 13).)
2011-08-19 20:10:25 ERROR Loading MovieInfo for \\...\MovieInfo.tvixie

When I check the XML document, I see this at the end:

</MovieInfo>tring>
<string>Derek Milosavljevic</string>
<string>Lesley Braden</string>
</Actors>
<Directors>
<string>Kevin Smith</string>
</Directors>
<Covers />
<Countries>
<string>USA</string>
</Countries>
</MovieInfo>

This is obviously wrong, as the XML file should end at the FIRST </MovieInfo> tag. So if I delete everything from "tring" and all the way to the end, and saves the file, I can edit the movie information as it was meant to be edited.

So, a workaround is possible, but not very practical in the long run. There must be an error when writing the XML-document after saving the info on the movies.

Strange thing, though, is that only a few movies are like this. Most of the movies (say about 75 %) works fine, but the rest won't edit without this workaround first.
maxschnell
 
Posts: 9
Joined: Fri Aug 19, 2011 8:05 pm

Share On:

Re: Can't edit movie information

Postby joma » Sat Aug 20, 2011 9:33 am

Hi,
I have never seen this before and noone have reported this kind of behaviour in the past.
Do you know which version of TViXiE who might have caused this behaviour? Are you getting these kind of corrupted XML files with the latest version?
/joma
joma
Development Team Leader
Development Team Leader
 
Posts: 774
Joined: Thu Aug 28, 2008 9:15 pm
Location: Sweden

Re: Can't edit movie information

Postby maxschnell » Sat Aug 20, 2011 10:55 am

Hi.

I have version 1.3.2 build 31709. That is the only version I have tried, so it must be related to that.
maxschnell
 
Posts: 9
Joined: Fri Aug 19, 2011 8:05 pm

Re: Can't edit movie information

Postby maxschnell » Sat Aug 20, 2011 11:03 am

Above I have written:
"...So if I delete everything from "tring" and all the way to the end, and saves the file, I can edit the movie information as it was meant to be edited."

This is not entirely correct. Even though that "fix" above does the trick most of the time, it's not the case all the time.

I can delete everything from after the original end-tag, save it, and click edit movie info again. And if nothing happens then, I see that the "wrong" ending has been added again. So the program must be writing to that "MovieInfo.tvixie"-file when I click edit movie (aka opens the movie-editing form), and not only when I click save.

I'll be more than happy to give detailed info on what happends when this error occurs. Just ask me!
maxschnell
 
Posts: 9
Joined: Fri Aug 19, 2011 8:05 pm

Re: Can't edit movie information

Postby coolstream » Sat Aug 20, 2011 12:45 pm

It seems that you have been very thorough in your faultfinding, but I wonder if you could attach a broken movieinfo.tvixie (in a RAR file) and I will see if I can replicate it both in 1.3.2 and 1.3.3beta .
Welcome back to TViXiE!
coolstream
Moderator
Moderator
 
Posts: 1460
Joined: Tue Jan 06, 2009 8:11 pm
Location: Scotland

Re: Can't edit movie information

Postby maxschnell » Sat Aug 20, 2011 1:17 pm

Here is the following files from two different movies:
- folder.jpg
- tvix.jpg
- MovieInfo.tvixie
- front_cover.tvixie

As you can see, the text added after the end tag in the xml-file differs from these two movies. As for "Batman Begin", you only have this:
/>
<Countries />
</MovieInfo>

...but on Any Given Sunday you have a lot more including a double MovieInfo end-tag:
</MovieInfo>ers />
<Countries>
<string />
</Countries>
</MovieInfo>ng>
<string>Al Pacino</string>
</Actors>
<Directors>
<string>Oliver Stone</string>
</Directors>
<Covers />
<Countries />
</MovieInfo>

I've also included a sub-log-file that starts from the point where I enter my film-folder. As you can see, it fails to load a lot of MovieInfo-files (due to an error in the xml-document).
At 12:59:22 I try to edit the movie info on "Any Given Sunday", and on 12:59:26 I try the same on "Batman Begins". Both with no luck.

As I've said before: don't be afraid to ask for any info from me!
Btw, I am a part-time programmer myself (mostly C#/.net), so don't be afraid to ask any "technical questions".
Attachments
Batman Begins.zip
(215.23 KiB) Downloaded 299 times
Any Given Sunday.zip
(192.41 KiB) Downloaded 318 times
TViXiE_sub.zip
This is a sub-part of my log-file
(1.2 KiB) Downloaded 298 times
maxschnell
 
Posts: 9
Joined: Fri Aug 19, 2011 8:05 pm

Re: Can't edit movie information

Postby coolstream » Sat Aug 20, 2011 11:56 pm

Thanks for the files. I will take a look at them tomorrow and get back to you.

EDIT: I couldn't resist taking a quick look and see that your files are on the TViX HDD itself.

Looking at your movieinfo.tvixie for 'Any Given Sunday', I can see that the line '/MovieInfo' occurs more than once. The first occurence looks really strange to me, almost as if two lines have been chopped and then concatenated.

Considering these two observations and the fact that you have so many XML errors, I am wondering if TViX itself has caused disk errors.

To check, connect TViX to PC via USB and run this command

chkdsk X: /F (where X is the drive detected by PC)

Let me know if that solves the problem ;)
Welcome back to TViXiE!
coolstream
Moderator
Moderator
 
Posts: 1460
Joined: Tue Jan 06, 2009 8:11 pm
Location: Scotland

Re: Can't edit movie information

Postby joma » Sun Aug 21, 2011 8:55 am

...to continue on Coolstream findings.
Are you connecting using FTP or SMB to your TViX player?
Please test to connect the player via USB to your computer and run TViXiE and see if the problem still persists.
/joma
joma
Development Team Leader
Development Team Leader
 
Posts: 774
Joined: Thu Aug 28, 2008 9:15 pm
Location: Sweden

Re: Can't edit movie information

Postby maxschnell » Sun Aug 21, 2011 8:59 pm

I can explain a little bit a more about how the problems occur.

Let's say I have gotten the info on "Any Given Sunday". I exit Tvixie, and opens it afterwards. If I then try to edit that movie, it doesn't work (as I've explained before). But when I then try to delete the info, and re-adds the film, the same thing happends. So it seems as if the problem is somehow related to the info given and/or the folder image or maybe the film itself? I have tried this with quite a few movies, and the same thing happends every time.

I ran the chkdsk /F command, and got the following result:
(translated from norwegian:) Fixing error in index $I30 for the file 390. Sorting index $I30 in the file 390.
That's it.

I have been connecting to the Tvix using a LAN cable connected to my router. But just now I tried to connect via USB (first disconnecting the LAN cable). I then tried to delete the movies "Any Given Sunday" and "Batman Begins" (that is, the movie info only, not the movie and folder picture), and re-add them. And you know what? After a little open, closing, editing and so on, it still worked just fine.
Then I disconnected the USB cable, and re-connected the LAN cable. I deleted the movie info on "Any Given Sunday", and re-added it, changing the folder icon and adding som more info. I closed Tvixie, re-opened it, and guess what happened? I could NOT edit the movie info.

So this little test gave me the following question: what is wrong with adding movies via LAN? It obviously doesn't work on some movies - for some mysterious reason...

And, as I have said before: please feel free to ask me if you need any info from me!
maxschnell
 
Posts: 9
Joined: Fri Aug 19, 2011 8:05 pm

Re: Can't edit movie information

Postby coolstream » Mon Aug 22, 2011 1:01 pm

OK, let's get specific...

You say 'I exit Tvixie, and opens it afterwards.'
Can you be more specific so that we can track down circumstances where corruption occurs? Does it need a restart of TViXiE, restart of PC etc?

Since I can edit the same movie titles (and they contain no strange characters) I doubt that could be the reason.

You say that chkdsk found an error and appears to have fixed it. I wouldn't necessarily expect a load of errors for problems to occur, so let's stick with this for a while.

After the error was corrected, did you try to edit folders with TViX connected via USB? With a corrupted MovieInfo.tvixie, editing will be impossible, so I presume you make a manual edit first and then attempt a TViXiE edit. And this causes no further problem until you switch off and reconnect later via a different method?

joma's question is very valid. Even though you say you attempt to copy files and edit over a network connection, are you connecting via Samba or FTP? If FTP, how do you make the connection (Windows proprietary or external program)? Have you tried using a different network cable?

When you disconnect USB cable, do you do 'Safe Removal' from PC?

After you find that you have corruption again, have you tried chkdsk again?
Welcome back to TViXiE!
coolstream
Moderator
Moderator
 
Posts: 1460
Joined: Tue Jan 06, 2009 8:11 pm
Location: Scotland

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest